Symbol/Footprint preview not working in search?
273 9
bryan costanich 9 months ago
For the last week or so, the preview hasn't been working for symbol/footprint search for me. It just spins: ![Screen Shot 2021-01-02 at 6.35.09 PM.png](//image.easyeda.com/pullimage/cAte2eFgjqhRLu8kvxeIdNAnt6cKkUuSofGra0cj.png) Anyone else seeing this?
Comments
andyfierman 9 months ago
Working ok for me last night.
Reply
bryan costanich 9 months ago
Weird. I just restarted my machine even and I'm still seeing the same issue. :( Unfortunately, it makes it nearly impossible to use the app.
Reply
andyfierman 9 months ago
Of the wall ideas... Ad blockers stop the floating toolbars from appearing. Are they OK in your setup? If you have one running, maybe try turning it off and see if the preview reappears. Otherwise, are you running behind a firewall? Proxy settings? Are you using the web-based or the Desktop Client versions? Have you tried using Firefox instead of Chrome?
Reply
bryan costanich 9 months ago
I'm using the desktop client version. So I wouldn't think any ad blockers would affect it. In any case, I wouldn't even know how to disable it for the desktop app. In fact, it shouldn't be enabled because extensions are per chrome window group. no firewall. no proxy.
Reply
andyfierman 9 months ago
Please change the category of this topic to Bug Report. That should get a faster response from EasyEDA support.
Reply
andyfierman 9 months ago
Try: ![image.png](//image.easyeda.com/pullimage/NlwVuLtbocUR5VudiWPj5tFLxIBedcHGqi52B8at.png) Or **Check Update...** then if all else fails, uninstall the Desktop Client and do a fresh install.
Reply
andyfierman 9 months ago
Does the preview work when you use the web-based version?
Reply
UserSupport 9 months ago
Your desktop client is too old to use the new API, suggest to use browser to open the editor.
Reply
hpcreery 8 months ago
The error appears to be a from the .js build of the application either not knowing when the SVG artwork fetch has finished or not mishandling the HTML elements. Seemingly there is a simple but temporary fix. 1. Open the Library, and right click on the preview window and select "Inspect Elements".![image.png](//image.easyeda.com/pullimage/IFYtMSyIkFIy99y0M6t8KgRiZN1RugvXKEeg0fpZ.png) 2. Select the HTML loading element and delete it. * It should appear in the DOM with the class name = "dlgLibs-preview-loading"![image.png](//image.easyeda.com/pullimage/2BpiSPL9mJGWQapgGdKmjoT03apYzUsPhbp4ogdT.png) 3. Then select the parent div for the previews, and uncheck the CSS element, display: none. * This element has the class name = " dlgLibs-thumbs"![image.png](//image.easyeda.com/pullimage/Ih7Krpqq3qrT23MIOvy3razv58cf1fnXEwCnl5NK.png) Now, you can close the developer tools pane and the previews will now show up on all items selected. Even closing the Library window and re-opening, will still work. Though quitting the application will reset the HTML DOM and issue will return. If you are listening EasyEDA devs, please fix the issue. OS X user here.
Reply
Login or Register to add a comment
goToTop
你现在访问的是EasyEDA海外版,使用建立访问速度更快的国内版 https://lceda.cn(需要重新注册)
如果需要转移工程请在个人中心 - 工程 - 工程高级设置 - 下载工程,下载后在https://lceda.cn/editor 打开保存即可。
有问题联系QQ 3001956291 不再提醒
svg-battery svg-battery-wifi svg-books svg-more svg-paste svg-pencil svg-plant svg-ruler svg-share svg-user svg-logo-cn svg-double-arrow
We use cookies to offer you a better experience. Detailed information on the use of cookies on this website is provided in our Privacy Policy. By using this site, you consent to the use of our cookies.