You need to Create a Project and stay online at least 60min in Editor for posting a Topic.
[solved] [After import] column empty when updating (Pro version) - Nets not updating
54 1
mijnmodelbaan 2 weeks ago
Hi, I finally managed to import a project from Std to Pro version of EasyEDA  ( [https://oshwlab\.com/mijnmodelbaan/mega\_motor\_n](https://oshwlab.com/mijnmodelbaan/mega_motor_n)  or  [https://pro.easyeda.com/editor#id=b14a59c4633d40fe93ae8cca917d5cfd](https://pro.easyeda.com/editor#id=b14a59c4633d40fe93ae8cca917d5cfd) ). I checked the footprints, updated the PCB, corrected the errors and saved everything. Closed editor and went to bed. Opened the project again this morning and checked the PCB for changes in the schematics (standard routine for me). To my surprise there were errors! So somehow the changes weren't saved or I made a mistake myself. So went to the schematic, clicked [Design] > [Update/Convert schematic to PCB] and found there were some 20 'Update Net' actions on the list, about half of the number from yesterdays list. I did then have a better look at the list and found all the 'After import' fields are empty: ![image.png](//image.easyeda.com/pullimage/r1LxDqgeex8eHxlV4Zixt12TmcBrHcnbOs870mjz.png) What am I doing wrong - what's (not) happening here - what did I forget ? There are 2 boards in the project. Each board has 5 components which go onto the PCB. Both boards show the same behaviour during updating. <br> Thanks in advance, BR//Willem. <br> [solution] The new concept of 'devices' solved this. I was using the imported symbols and footprints and this caused the error. After replacing the L1 component with a newly created device all worked fine.
Comments
UserSupport 3 days ago
Hi if your part's pin doesn't connect any wire which named by netflag, you will get the empty pads net
Reply
Login or Register to add a comment
goToTop
你现在访问的是EasyEDA海外版,使用建立访问速度更快的国内版 https://lceda.cn(需要重新注册)
如果需要转移工程请在个人中心 - 工程 - 工程高级设置 - 下载工程,下载后在https://lceda.cn/editor 打开保存即可。
有问题联系QQ 3001956291 不再提醒
svg-battery svg-battery-wifi svg-books svg-more svg-paste svg-pencil svg-plant svg-ruler svg-share svg-user svg-logo-cn svg-double-arrow
We use cookies to offer you a better experience. Detailed information on the use of cookies on this website is provided in our Privacy Policy. By using this site, you consent to the use of our cookies.