You need to use EasyEDA editor to create some projects before publishing
Auto Router completes but does not route all nets
1058 4
DeeEmm 1 year ago
Hi all. I've been using the desktop pro version to update an older project previously designed with the original online standard editor. The Editor is definitely nicer to use although the workflow of some aspects take a little getting used to. I have now however stumbled onto an issue. When autorouting I have found that in the pro version the process finishes but does not route 100% of the nets. The best I have managed to do is about 86%. No amount of manually moving and reorientation components or adjusting the routing rules will get it to complete 100%. So as a test I exported the project as an Altium package and then imported it into the standard version. I then re-tried autorouting and the project completed 100% with no issues, even using cloud autorouting. The autorouting engine is visually different in the pro version as the nets are routed at 90 degrees even though 45 degrees is selected and then at the end of the process the 'corners' are swapped to 45 degrees. Clearly the engine in the pro version is different from that used in the online and local routing engines and it does not appear to route correctly. Pro version routing .... ![Screenshot 2023-02-21 at 4.51.38 pm.png](//image.easyeda.com/pullimage/nCQ35E0Xafy9pat09UefiEXqNcZIpacDrbonVhGx.png) <br> Regular version routing .... ![Screenshot 2023-02-21 at 4.53.25 pm.png](//image.easyeda.com/pullimage/SQNTu64NAWlHbPw1w2J2NqpYcmLtfKzLA3hK8Zyb.png) Both are set to route at 45 degrees. I'm not sure if this is an environment issue, or that the pro version router is less permissive in its operation. However the standard version appears to be heaps better and far more refined. It also generates a result. So I have the following questions Assuming it's a setup issue, how can I set up the pro version auto routing to act the same as the regular version. Is this even possible? Is there a workflow where I can achieve the same outcome or perhaps use the existing local EDA router? Is this problem a known issue / limitation? I am happy to invite support to the project if you think that it's a project issue, but it is not a public repo so I am unable to share it here I'm not really interested in people telling me that I should manually route it. Some aspects of the project are manually routed prior to auto routing the rest, but the issue remains that the pro router fails to route what is a pretty simple project even without predefined manual nets. Thanks in advance. /DM
Comments
DeeEmm 1 year ago
OK. I've just managed to get it to route 100% for the first time by flipping some components to the bottom of the board. So the router obviously works. But I'd like to understand why it is so different from the standard version. Given that the rules being used are essentially the same. To me it seems that track clearances are reduced by the way that it routes (90 degrees instead of 45 degrees). Is this observation correct? Or is it a setup / environment issue? Why am I not getting the same results as the standard version? /DM
Reply
Zunuran Nasrullah 1 year ago
I have tried auto routing in pro version and it definitely requires more updates as its full of bugs. I will also suggest you to not use auto routing in pro version as of now. One of the biggest problems is that it routes the signals very close to eachother which are not good for signal integrity at-all
Reply
DeeEmm 1 year ago
Thanks Zunuran. Good to know it's not just me. I guess the standard version is a lot more mature and the pro version has a bit of catching up to do. I think that for the time being I'll be sticking with the standard version until some of these bugs are ironed out.
Reply
DeeEmm 1 year ago
On further inspection of my 'successful' 100% routing on the pro version I now note that there are 50 DRC errors including including the following... ![Screenshot 2023-02-22 at 9.25.48 am.png](//image.easyeda.com/pullimage/hEfNEOKJOfxTDtrd4HXyxBc72yenYAq5N9XsvFQN.png) It makes no attempt to clear the pads when routing tracks. This is clearly not ready for mainstream. I'd say this is Beta level software at best. /DM
Reply
Login or Register to add a comment
goToTop
你现在访问的是EasyEDA海外版,建议访问速度更快的国内版 https://lceda.cn(需要重新注册)
如果需要转移工程请在个人中心 - 工程 - 工程高级设置 - 下载工程,下载后在https://lceda.cn/editor 打开保存即可。
有问题联系QQ 3001956291 不再提醒
svg-battery svg-battery-wifi svg-books svg-more svg-paste svg-pencil svg-plant svg-ruler svg-share svg-user svg-logo-cn svg-double-arrow -mockplus- -mockplus- -mockplus- -mockplus- -mockplus- -mockplus- -mockplus- -mockplus-@1x -mockplus-

Cookie Notice

Our website uses essential cookies to help us ensure that it is working as expected, and uses optional analytics cookies to offer you a better browsing experience. To find out more, read our Cookie Notice