Bug: Very complex PCBs trigger misleading "Cannot connect to server" message when Save is attempted.
57 2
MadOverlord 2 weeks ago
I have a board with a lot of components and traces. It loads and saves fine. However, if I add some more components (about 30 in this case), while the PCB loads and edits normally, when I attempt to save it, I get a "Cannot connect to server" popup. This message is misleading because the server is up and active (I can save other PCBs in other tabs). There's something about the complexity of the board (or perhaps the sheer size) that is causing the server to respond anomalously. I am able to save the JSON to a local file - it's 7.2MB long! If there is a limit, it would be nice if the error message let you know what the problem actually is. It would be nicer if the PCB editor let you know when you were getting close to the limit. If you need more information, let me know. I can probably rig up a project that demonstrates the problem (perhaps with the extra components set with Convert to PCB = No so you can just toggle them on and off). Obviously, I can't point you to a project that contains a PCB that can't be saved, because I can't save the PCB (hahahah!) Best, Robert
Comments
UserSupport 2 weeks ago
Does this PCB save fail all the time? please send it to us, we will have a look. [[email protected]](mailto:[email protected]) the size for per file is limited in 15MB it should can be saved, we need to check if something influence Thanks
Reply
MadOverlord 1 week ago
Hmmm... it does not appear to be repeatable after I got a good night's sleep! I tried reloading the EasyEda PCB JSON I'd saved locally when I ran into this issue. It first gave me a "document not found" dialog box that was non-responsive, but after about 10 seconds the PCB appeared. I tried saving that into the project and it saved properly this time. OK, so I went back to my current version of the PCB (I'd been doing other edits in the meantime without adding new components) and added the 34 components that had apparently triggered the issue the first time. This time I saved immediately after updating the PCB. It saved OK. I did the PCB editing I'd done before, placing the components properly. Again, it saved OK. So this seems to have been a transient problem, and it's unclear exactly what caused it in the first place. I would mark this as "closed, nonrepeatable" for now, but if I run into an repeatable example, I'll send it to you. And of course, if someone else runs into the same issue perhaps they'll have some insights. One takeaway: if someone else does run into this problem, they should try saving the PCB JSON locally and then opening the file again. It might "fix" it. As always, thank you for your quick response! Best R
Reply
Login or Register to add a comment
goToTop
你现在访问的是EasyEDA海外版,使用建立访问速度更快的国内版 https://lceda.cn(需要重新注册)
如果需要转移工程请在个人中心 - 工程 - 工程高级设置 - 下载工程,下载后在https://lceda.cn/editor 打开保存即可。
有问题联系QQ 3001956291 不再提醒
svg-battery svg-battery-wifi svg-books svg-more svg-paste svg-pencil svg-plant svg-ruler svg-share svg-user svg-logo-cn svg-double-arrow
We use cookies to offer you a better experience. Detailed information on the use of cookies on this website is provided in our Privacy Policy. By using this site, you consent to the use of our cookies.