You need to use EasyEDA editor to create some projects before publishing
Custom Attributes does not work properly
968 10
Klyuzhev 2 years ago
1\. On schematic of "Project A" I add 3 custom attributes for every component \- "Replacement 1"\, "Replacement 2"\, "Replacement 3" to use them for alternative parts\. They appear in BOM as expected, everything OK. ![image.png](//image.easyeda.com/pullimage/vXbKwUrlWqn3sztinsb3tBuoQuiawUQ8yXNxDhHH.png) 2\. On schematic of "Project B" I have not seen "Replacement 1"\, "Replacement 2"\, "Replacement 3"\, so I created them again on this schematic\. 3\. I return back to schematic of "Project A"\. Now I see multiple "Replacement X" parameters in list\! ![image.png](//image.easyeda.com/pullimage/6lU6Q2sy6TfB849bHmRuCPLUIuuAsBKgV3L6OvpQ.png) 4\. And what is much worse \- I can not add any of these "Replacement X" to BOM anymore\! I chose "Replacement 1", fill some p/n to Value field, save changes, open BOM and see "Replacement 1" empty! ![image.png](//image.easyeda.com/pullimage/E7AF6iBmZat80NiEUxo8GUTFgt6XS8TZoEcm4jKM.png) Please, help to fix this bug or give advice how resolve it.
Comments
jogagua 2 years ago
I have also found problems with **Custom Attributes**. I always add custom parameter '**Description**' to all my components. Today I started modifying a project that I created a few months ago and when I try to add my custom parameter to the new components, it do not appear in the BOM. ![image.png](//image.easyeda.com/pullimage/ogUxDJS9bC4Gcr8CWmhVkDn14W86dKIUL9Ht2s86.png)      ![image.png](//image.easyeda.com/pullimage/9CQ3G7e39yR80T06shOB0vaZexRhAR23YmctOiWX.png)     ![image.png](//image.easyeda.com/pullimage/1H41SZeZCgc89KPDCwpnnMWa8E7b0jJYqdBI48Wv.png) I remember that before we had a CheckBox 'In BOM', that now disappeared. ![image.png](//image.easyeda.com/pullimage/601dmqF4LAOlfxI4BNEKt9pwoiAdWGnEufEoznXR.png) Can you verify please? Thanks in advance. <br> <br>
Reply
jogagua 2 years ago
I found a workaround in order to add the parameter '**Description**' and see it in the BOM. You have to select the component to which you want to add the parameter 'Description' and a component that already has that parameter. You will see something like this: ![image.png](//image.easyeda.com/pullimage/75FoZRtl2mVgDzGpaCVjUCG2t8gTXakNCHDlA7CH.png) Since I had already tried adding the 'Description' parameter, I see two of them. You have to delete the one you can read. And in the one you cannot read, you write anything: ![image.png](//image.easyeda.com/pullimage/f0lGRfSESVpasnb5TCsF3d84BUyxuVstBwZsTqSP.png) Then you can select the components separately and change the value of the custom parameter. ![image.png](//image.easyeda.com/pullimage/fVIpba1kuVGdbx8WOVrp0AqGyjsmuXAHj8eFCmC9.png)  ![image.png](//image.easyeda.com/pullimage/XE72olKJi4orUIlejCrsVLWKHcpZqiZ2f4GVAaZ5.png) Now the BOM is OK: ![image.png](//image.easyeda.com/pullimage/x5bLYGkXrrHRvkO45hSpJXSQ8kcISNLyXiPIvLEn.png)
Reply
jogagua 2 years ago
errata: **You have to delete the one you can read** -> **You have to delete the one you can't see in the BOM**
Reply
Klyuzhev 2 years ago
@jogagua How to fix it? They are doubled. Schematic contains many components. How to chek them all... ![image.png](//image.easyeda.com/pullimage/KQo3fduLku8sDgYtITuDhZEgnLoNGlPJrHU6WgEz.png)
Reply
UserSupport 2 years ago
Add new parameter only support for one project, if you want to add the same key at other project you need to add it again since 6.4.20.6, we remove the Add into Bom option, because of when export the BOM, you can chose the parameter key as you want, you don't need to set Add into BOM again.
Reply
Klyuzhev 2 years ago
> Add new parameter only support for one project, if you want to add the same key at other project you need to add it again > since 6.4.20.6, we remove the Add into Bom option, because of when export the BOM, you can chose the parameter key as you want, you don't need to set Add into BOM again. Why they start duplicating? ![image.png](https://image.easyeda.com/pullimage/KQo3fduLku8sDgYtITuDhZEgnLoNGlPJrHU6WgEz.png)
Reply
Wilder Gomez 2 years ago
HI [Klyuzhev](https://easyeda.com/Klyuzhev), were you able to fix your issue ? I have been updating my project BOM but it wont display when I click on it, similar to yours
Reply
Klyuzhev 2 years ago
@wilder.gomez No, I can not find proper way to fix that stupid bug. Especially on big schematic with a lot of components.
Reply
Wilder Gomez 2 years ago
@Klyuzhev  I was able to fix it manually, I also received the PCB and it worked but yes it was a hustle
Reply
UserSupport 2 years ago
Hi The new custom properties only for the current project files Can you repeat this issue at v6.4.29? I cannot repeat it, please send your schematic as EasyEDA format and send to [support@easyeda.com](mailto:support@easyeda.com) we will help to check thanks
Reply
Login or Register to add a comment
goToTop
你现在访问的是EasyEDA海外版,建议访问速度更快的国内版 https://lceda.cn(需要重新注册)
如果需要转移工程请在个人中心 - 工程 - 工程高级设置 - 下载工程,下载后在https://lceda.cn/editor 打开保存即可。
有问题联系QQ 3001956291 不再提醒
svg-battery svg-battery-wifi svg-books svg-more svg-paste svg-pencil svg-plant svg-ruler svg-share svg-user svg-logo-cn svg-double-arrow -mockplus- -mockplus- -mockplus- -mockplus- -mockplus- -mockplus- -mockplus- -mockplus-@1x -mockplus-

Cookie Notice

Our website uses essential cookies to help us ensure that it is working as expected, and uses optional analytics cookies to offer you a better browsing experience. To find out more, read our Cookie Notice