Gerber files generated without Inner planes
157 5
htlin 5 months ago
Inner planes were missing in the Gerber files generated for my two new designs using EasyEDA. The problems were discovered by JCLPCB. In one case, inner plane 1 was missing and in the other one, inner planes 1 and 2 were both missing. I went back to my design files and were able to export all the layers including the inner planes to PDF files without any problem. In all my previous designs, the inner planes were setup as "Signals" in the Layer Manager and never had any missing inner plane issues. However, in the two new designs, the inner planes were setup as "Plane" in Layer Manager due to the odd shape of the PCB. I used Layer Manager to change the inner plane setup to "Signal" and regenerate the Gerber files. The Gerber files generated in this case were correct with no missing inner planes. H. Lin
Comments
UserSupport 5 months ago
please check the plane zoom fill type: if you set it as Yes, it will not generate the plane copper. ![图片.png](//image.easyeda.com/pullimage/EQ7vC6JDYDagjoXOd5M1wGmaLb7FzC9s4vFDsohO.png)
Reply
andyfierman 5 months ago
@UserSupport, I think the option for the copper plane should be "Solid" and not "No Solid". A "Yes/No" response to the "No Solid" option is confusing because answering a negative question with a simple "Yes/No" choice creates an ambiguity. Suppose you want a coffee with milk so you go into a cafe and ask for a coffee. The waiter asks you "No milk?" If you can only answer "Yes" or "No" it is not clear from the question, what the appropriate answer should be to get a coffee with milk. Is the waiter actually asking "Do you want a coffee with **no** milk in it?" In which case you would answer "No". Or is the waiter really asking "Do you want a coffee **with** milk in it?" In which case you would answer "Yes". If the waiter had asked "Milk?" then there would be no ambiguity. * Therefore the option for the copper plane should be "Solid"
Reply
UserSupport 5 months ago
@andyfierman You are right, it is confusing, we will change it next release. Many Thanks
Reply
htlin 5 months ago
The Correct answer to "No Solid" is "No". I regenerated Gerber files with the "NO" setting and the inner planes appeared. Andy was right on about the confusion. What added to the problem  was that all planes were present using "Export PCB design to PDF" option. Regards, H. Lin
Reply
UserSupport 5 months ago
@htlin  @andyfierman Hi It fixed at v6.1.49, Thanks
Reply
Login or Register to add a comment
goToTop
你现在访问的是EasyEDA海外版,使用建立访问速度更快的国内版 https://lceda.cn(需要重新注册)
如果需要转移工程请在个人中心 - 工程 - 工程高级设置 - 下载工程,下载后在https://lceda.cn/editor 打开保存即可。
有问题联系QQ 3001956291 不再提醒
svg-battery svg-battery-wifi svg-books svg-more svg-paste svg-pencil svg-plant svg-ruler svg-share svg-user svg-logo-cn svg-double-arrow
We use cookies to offer you a better experience. Detailed information on the use of cookies on this website is provided in our Privacy Policy. By using this site, you consent to the use of our cookies.