Local autorouting "Connection closed"
950 14
Andrea Esposito 8 months ago
Hi I have some issue in the last few days. I'm using win10, Chrome 79.0.3945.130 (Build ufficiale) (a 64 bit) and the latest binary autorouting. Very often, I don't know why, autorouting doesn't work. The warning "Connection closed" appears in the shell: > c:\EasyEDA-Router-v0.8.10>win64.bat > Auto Router now running... > \-\-\-\-\-\-\-\-\-\-\-\-\-Connection established\-\-\-\-\-\-\-\-\-\-\- > Start routing... > Routing > \-\-\-\-\-\-\-\-\-\-\-\-\-Connection closed\-\-\-\-\-\-\-\-\-\-\-\-\-\-\- I believe there is some communication problem between the binary and the browser. It is not a routing problem, is something related to sockets ... How can I solve it? thanks
Comments
UserSupport 8 months ago
if editor finish or stop routing, the command shell will show connection closed
Reply
Andrea Esposito 8 months ago
@UserSupport I know this. But I noticed that sometimes I have to: 1\. press the "Cancel" button in the routing window 2\. do Control \+ C in the shell 3\. recall the routing to start the procedure again Until a few weeks ago I had no such problems...
Reply
Ronald Dehuysser 7 months ago
I also have this problem now - autorouter is not working at all. I saved a clone of my PCB when autorouting was working and now, in that cloned version, autorouting is not working anymore. What to do? Control+C of the local router in the shell does not help...
Reply
Andrea Esposito 7 months ago
Try to press "Cancel" then re-route again!
Reply
scalesr1 7 months ago
I just posted a new Bug report but I can see that it is the same issue as you are all having. Does anyone have a resolution for this yet?
Reply
Miles Taylor 7 months ago
Thanks Andrea, your work-around got me going!  Hopefully this will be fixed soon.
Reply
GunhterRedox6943 7 months ago
Win64.bat say: **_Autorouter is running, please keep this window opening? and run the editor "Auto Router" function..._** **_??????????????????????????????????..._** **_\-\-\-\-\-\-\-\-\-\-\-\-\-Connection established\-\-\-\-\-\-\-\-\-\-\-_** **_Start routing..._** **_\-\-\-\-\-\-\-\-\-\-\-\-\-Connection closed\-\-\-\-\-\-\-\-\-\-\-\-\-\-\-_** same problem for me the "Auto Router is running ..." but nothing the connection closes directly after you press Start. locally or on the server, it no longer works. EsayEDA local V6.3.22, W10
Reply
UserSupport 7 months ago
@milestaylor999 @GunhterRedox6943 please try routing manually, using routing conflict as RoundTrack the auto router is not good. we will write our new auto router in the future. ![image.png](//image.easyeda.com/pullimage/b1iIT6emjRKFEuTZ28FhxmjpDlNrFt6kaZl6OsJJ.png)
Reply
Hakan DONUK 6 months ago
I have been a victim of the same problem for a few days. Please, I would be glad if they find a solution. Thank you. Good work.
Reply
Natalie.sch 6 months ago
It does not work yet. Maybe someone has a solution.
Reply
Elettronic 5 months ago
To date there is always the same problem, but has anyone tried to use Linux with Auto Router?  Thank you very much for the attention
Reply
polonkailaszlo 3 months ago
The warning "Connection closed" appears in the shell when I use accented characters. Do not use accented or special characters.
Reply
WarEnd 1 week ago
Same problem to me. I try in windows 10 and ubuntu on linux. Still get connection closed. Its started after software update :(
Reply
andyfierman 1 week ago
@WarEnd, You have not given enough information for anyone to help you. Please read: [https://easyeda.com/forum/topic/How-to-ask-for-help-and-get-an-answer-71b17a40d15442349eaecbfae083e46a](https://easyeda.com/forum/topic/How-to-ask-for-help-and-get-an-answer-71b17a40d15442349eaecbfae083e46a)
Reply
Login or Register to add a comment
goToTop
你现在访问的是EasyEDA海外版,使用建立访问速度更快的国内版 https://lceda.cn(需要重新注册)
如果需要转移工程请在个人中心 - 工程 - 工程高级设置 - 下载工程,下载后在https://lceda.cn/editor 打开保存即可。
有问题联系QQ 3001956291 不再提醒
svg-battery svg-battery-wifi svg-books svg-more svg-paste svg-pencil svg-plant svg-ruler svg-share svg-user svg-logo-cn svg-double-arrow
We use cookies to offer you a better experience. Detailed information on the use of cookies on this website is provided in our Privacy Policy. By using this site, you consent to the use of our cookies.