[Solved] PCB opens off window
66 8
vdeconinck 2 weeks ago
Hi, Disclaimer: this may be a user mistake, but I don't know how to fix it. For months, each time I open my PCB, nothing seems to show up because the actual PCB is off-screen. I have to zoom out a lot to find it, then center it on the window, and finally zoom back in to start working : [https://www.screencast.com/t/1uvmWpw9WbS](https://www.screencast.com/t/1uvmWpw9WbS) It was not the case when I started working on that PCB of course and I don't know what happened, but I cannot reverse it. Any idea ? Thanks,  V.
Comments
andyfierman 2 weeks ago
This is almost certainly because you have placed something way outside the Board Outline. Check **Design Manager > Components** to find it.
Reply
MikeDB 2 weeks ago
@andyfierman No I've got one PCB that has started doing the same thing recently.  I have trawled everywhere to find something off-piste but can't.  Oddly enough it's the same PCB that sometimes reports zero components in my latest bug report.
Reply
UserSupport 1 week ago
Press hotkey K , find out what objects offseted with the center.
Reply
UserSupport 1 week ago
we don't know what happen in this object yet.
Reply
vdeconinck 1 week ago
Hi. Thanks very much for the quick replies. After pressing K, I was faced with (what I thought was) a mostly empty page: ![Offscreen PCB + hotkey K](//image.easyeda.com/pullimage/dxBOsxC1RVK48GLfVJ3tzVODpjcF7xhn7ja29cZV.png) However, when dragging a big selection rectangle in the "empty" part on the left, the right pane said "Selected object : 1" and " Via properties ..." So even though I could not see it, I pressed the "Delete" key then "K" again and now my PCB is centered again as expected. I don't know how that via was created in that corner, but my problem is solved and most probably it was my mistake. Thanks again and sorry for the silly question. KR, V.
Reply
vdeconinck 1 week ago
PS : oh, and by the way, Andy, "Design Manager > Components" was of no help, as it was not a component... But thanks anyway :-).
Reply
andyfierman 1 week ago
Sorry, I  forgot to say do the K hockey thing first. It may have shown up checking either the nets attached to each component or, if it wasn't connected to anything else, just checking for an unconnected Net because EasyEDA auto assigns netnames to everything that can form part of a net.
Reply
andyfierman 1 week ago
A quick fix is to make a backup copy of the pcb then, in the original PCB, press the K hotkey then select and copy everything that is part of the **original** pcb. Then select **everything** in the original pcb, delete it and then paste your copy of the wanted pcb back onto the canvas. Check it, save it. Done.
Reply
Login or Register to add a comment
goToTop
你现在访问的是EasyEDA海外版,使用建立访问速度更快的国内版 https://lceda.cn(需要重新注册)
如果需要转移工程请在个人中心 - 工程 - 工程高级设置 - 下载工程,下载后在https://lceda.cn/editor 打开保存即可。
有问题联系QQ 3001956291 不再提醒
svg-battery svg-battery-wifi svg-books svg-more svg-paste svg-pencil svg-plant svg-ruler svg-share svg-user svg-logo-cn svg-double-arrow
We use cookies to offer you a better experience. Detailed information on the use of cookies on this website is provided in our Privacy Policy. By using this site, you consent to the use of our cookies.