Pad center-snap region a little too large
819 8
martin 4 years ago
It often happens that you have a via (for example) really near the center of a pad. In some cases, the via naturally falls within the center snap region of the pad, making it nearly impossible to create a trace between the two. Is there a key to suppress center pad snapping momentarily? ie, start at center of pad, suspend center snapping, connect to via, continue on your merry way.
Comments
andyfierman 4 years ago
You can toggle snap to grid on and off using the `G` key. This is a global function so don't forget to turn snap to grid back on.
Reply
martin 4 years ago
Actually, the pad center-snap feature doesn't respect the global Snap preference. It always snaps.
Reply
andyfierman 4 years ago
I hadn't realised that! As you have probably already found, the pad snap also does not respect the snap size setting.
Reply
martin 4 years ago
Andy, I don't think it should respect the size setting, either. The intent is to snap to its center no matter what. I find that to be very useful. Perhaps it could be tweaked to always snap to the center of the pad, within a region defined by the snap size?
Reply
martin 2 years ago
Coming back to this: the snap region on pads _actually scales_ with zoom, which is undesirable. It really should be independent of zoom, and use actual mouse distance from center. In the image below, my mouse is hovering directly over the via, but notice the focus dot is in the center of the pad. It makes it impossible to connect the two! ![enter image description here][1] [1]: /editor/20180130/5a705b4b313fe.png
Reply
Henrik Larsen 5 days ago
I have problems with this also. Tracks snap to pad and controls track routing from the PAD to the first bend. I my particular case, i wire a very thick trace through narrow area, but the PAD snapping prevents me from doing routing from the PAD off center. If I pull the angled track down a bit, it just jumps back to PAD center. What should I do here ? ![image.png](//image.easyeda.com/pullimage/ZWVu9NLFgtSrsWFyc1sJCHZk3JRUwPMjbec7SBAt.png) I want it to be like this, but I cant leave it there. It pops back. ![image.png](//image.easyeda.com/pullimage/pNGgvOTiLmt50ORlSbRygRZok1JoZlE5pk6zAKRK.png) Its very annoying, that PAD snapping cannot be disabled.
Reply
martin 5 days ago
4-year-old thread, still not resolved. These annoyances add up. Center-snapping to pad should use camera coordinates. ie, snap should happen based on distance of pad to mouse as seen on-screen, so that zooming in allows gives more accuracy. Alas, this small improvement is apparently at the bottom of the pile, as are so many others.
Reply
martin 4 days ago
Bump, EasyEDA team. It's been 4-years for what could be a quick fix. Change coordinate space for pad snaps!
Reply
Login or Register to add a comment
goToTop
你现在访问的是EasyEDA海外版,使用建立访问速度更快的国内版 https://lceda.cn(需要重新注册)
如果需要转移工程请在个人中心 - 工程 - 工程高级设置 - 下载工程,下载后在https://lceda.cn/editor 打开保存即可。
有问题联系QQ 3001956291 不再提醒
svg-battery svg-battery-wifi svg-books svg-more svg-paste svg-pencil svg-plant svg-ruler svg-share svg-user svg-logo-cn svg-double-arrow
We use cookies to offer you a better experience. Detailed information on the use of cookies on this website is provided in our Privacy Policy. By using this site, you consent to the use of our cookies.