Schematic Annotation does not update prefixes in PCB so creates new ratlines
1068 4
andyfierman 4 years ago
**BUG** Concise problem statement: Once a schematic has been passed to PCB and tracked, if the schematic is re-annotated and those changes imported into the PCB, then the component prefixes are not re-annotated. This then draws new ratlines because the the connectivity has changed but physical placement of the parts has not. * Note that I think this may be part of the problem reported in: https://easyeda.com/forum/topic/Shematic_connections_are_not_perfectly_interpreted_when_exported_to_PCB-0C2CbLXx7 Steps to reproduce bug: Using: https://easyeda.com/andyfierman/No_join_dot-rGgCcMK53 1. Draw a schematic. This is `Annotate problem 1 (original cct)`; 2. Pass to PCB, layout and track. This is `Annotate problem 1 (original PCB)`; 3. Re-annotate schematic in Rows. This is `Annotate problem 2 (after Row Annotate)`; 4. Import changes into PCB. This is `Annotate problem 2 (PCB after Row Annotate)`. Results: Component prefixes have not changed to match imported changes therefore connectivity no longer matches existing tracking so ratlines appear. Expected results: Component prefixes changed to match imported changes so connectivity continues to match tracking on PCB layout therefore ratlines no appear. Browser: Chrome and Firefox in Windows and Linux.
Comments
dillon 4 years ago
Hi, Import change, EasyEDA dosen't remove the tracks and we build the new ratlines. If you try to run a DRC, you will find the problems, this situation, you must remove the tracks by manually .
Reply
andyfierman 4 years ago
If I changed the connections (wiring) between the components in the schematic then when I import changes into the PCB, I would expect to have to delete and draw new tracks. * To understand my point you have to think about the problem the other way round. Suppose I number the parts in a schematic and then place them on a PCB and track them. Then I decide to use Annotate to renumber the parts in the schematic to make it easier to read them in the schematic. Or maybe I manually change the prefixes in the schematic for the same reason. I don't want - and should not need - to change the PCB layout. All the parts and tracks are in the correct physical places on the board. All I have done is change the component numbers. I should not have to retrack the board for that. There should be a way to tell EasyEDA to just swap the prefixes in the PCB to match the new schematic numbering and not to swap the connections. Maybe there needs to be an options in **Import Changes** to: **Update prefixes only** Selecting **Update prefixes only** would do what I am describing. Or, maybe doing: **Super Menu > Miscellaneous > Annotate** could be made to automatically update only the prefixes in the PCB without the user having to manually do: **Import Changes** At present, I think the way **Import changes** works after changing the schematic prefixes is (a) causing some of the problems that koosjr is seeing and (b) could be done in a better way that saves the user from having to retrack a board just becuase they want to change the component prefixes.
Reply
dillon 4 years ago
Hi, retrack is not easy in codes.
Reply
dillon 4 years ago
https://beta.easyeda.com/koosjr/Biltong_Blitz_Shield-TQK2WewOI Spend lots of time to locale the bug.
Reply
Login or Register to add a comment
goToTop
你现在访问的是EasyEDA海外版,使用建立访问速度更快的国内版 https://lceda.cn(需要重新注册)
如果需要转移工程请在个人中心 - 工程 - 工程高级设置 - 下载工程,下载后在https://lceda.cn/editor 打开保存即可。
有问题联系QQ 3001956291 不再提醒
svg-battery svg-battery-wifi svg-books svg-more svg-paste svg-pencil svg-plant svg-ruler svg-share svg-user svg-logo-cn svg-double-arrow
We use cookies to offer you a better experience. Detailed information on the use of cookies on this website is provided in our Privacy Policy. By using this site, you consent to the use of our cookies.