Silk layer does not save
738 30
lutecki 10 months ago
Hi, I designed PCB a few days ago (start/stop HR on my account). Today I try print before ordered but I saw silk layer is... mixed up. I thought I did not save before closing, so I dedicate another 30 minutes to set the description layer. I use photo view - everything is all right. I saved project, close browser, open easyeda again and I see again mixed silk layer.
Comments
andyfierman 2017-07-06 02:53:53
Can you make your project public so we can see it to investigate? If not please share privately with ![enter image description here][1] https://easyeda.com/Doc/Tutorial/Share.htm#Sharing [1]: /editor/20170610/593c042e0edb9.png
Reply
lutecki 2017-07-07 13:02:00
I share you my project. I try again change silk layer, moved names to good places, saved project, generate PCB photo, close window project, open again and... ![enter image description here][1] ![enter image description here][2] [1]: http://i.imgur.com/JLj7Acb.png [2]: http://i.imgur.com/vXMB4Pi.png
Reply
support 2017-07-07 14:04:34
It is very strange, I test lots of time , these text is changed to new place, Test under windows Chrome and Mac Chrome ![enter image description here][1] [1]: /editor/20170707/595f24584b7fe.png
Reply
lutecki 2017-07-07 15:49:08
Normally, I use Safari, for testing I try used FF. When I moved 1, 2, 3, 4... items and saved everything was fine. On safari also. But when I set all the elements again as they should be (silk layer), saved, closed the browser and reopened the project again, everything is messed up.
Reply
lutecki 2017-07-13 17:55:05
OK, I know where is the problem and where is the bug. Go to my project, move silk of one, two elements, save project, close, open again - everything is all right. Now move R13 silk and save project. All previous items will be preset at the pre-save location.
Reply
support 2017-07-13 18:05:00
@lutecki Yes, we found it, Maybe just R13 problem, we need some time to dig it. Thanks
Reply
demianaa 2017-09-09 16:15:52
Hi,I am experiencing this issue as well, every time I reopen the project the silkscreen labels of most all components "reset" there position (not rotation). This is quite frustrating as I then have to reposition ~100 labels every time I want to export. Using: Firefox 55.0.3
Reply
demianaa 2017-09-09 16:48:43
Hi, I have tested in Chrome (Version 61.0.3163.79) as well - same issue. It seems to be in version 4.8.5 the bug appeared...when I launched Chrome the first time (haven't used Chrome on this PC for a while) it opened the project in an older version of EasyEda, and everything looked fine. After refreshing the page to version 4.8.5 the labels where once again rearranged. I don't think it is a "saving issue" - all though it may overwrite if You save the scrambled labels - as the preview on the project-page look fine...
Reply
lutecki 2017-09-09 19:56:35
I have this same issue and this is not browser problem. But I know, you have one (or more) element who make this issue. If you have a time, you can find this element. How? Move fiew silk layer elements, save, close browser and reopen. And again, again, again... When your silk layer has reset I have reason who element make this issue. But EasyEDA don't remove this problem to this time...
Reply
dillon 2017-09-10 08:51:08
@demianaa @lutecki The problem is we can't reproduce this problem. After test
Reply
dillon 2017-09-10 08:51:33
@demianaa @lutecki can you post any images at here.
Reply
demianaa 2017-09-11 01:02:30
@Dillon I've shared the project with [email protected] Here's a screen-shot for the editor: ![Silk in editor][1] Here's what it looks like if I export as image: ![Silk exported][2] [1]: /editor/20170911/59b56fcccb1fb.jpg [2]: /editor/20170911/59b5700f69821.jpg
Reply
demianaa 2017-09-11 01:04:48
@Dillon The second image looks the way it did last time I saved the project - before Gerber export.
Reply
demianaa 2017-09-11 01:11:48
@Dillon The Gerber files match the view in the editor (first image).
Reply
dillon 2017-09-11 07:56:29
@demianaa Which text you changed ?
Reply
demianaa 2017-09-11 08:32:01
@Dillon This time none of it - I exported the image from the editors file-menu but it's the exact same file. You can see that almost all of the labels have moved in the editor-view. This however means that I will have to rearrange all of the labels if I want to make changes and save the file, or if I want to export for production. I have no idea witch components might be causing the issue I frankly don't have the time/will to go through them one by one, right now as lutecki did. I have already ordered the PCB's this time around. If I find a specific component that resets the label positions haha - I will of course let You know - but I hope the issue is resolved by then =)
Reply
support 2017-09-11 11:48:44
@demianaa We are sure this is a bug of Firefox. Chrome should be OK. If you are hurry, you can try Chrome, we will upgrade a new version to hack the Firefox problem
Reply
demianaa 2017-09-11 11:52:05
@support As stated above I have already tried in Chrome and the problem exists there as well.
Reply
demianaa 2017-09-11 12:01:23
@support Hi. I just tried Chrome again in an older version (*60.0.3112.113 (Officiel version) (64-bit)*) and all was fine, but after updating to Version *61.0.3163.79 (Officiel version) (64-bit)* the problem was back. (Tested with the version I have shared - no saving)
Reply
demianaa 2017-09-11 12:03:26
@Suport *PCB* version I have share *for clarity..
Reply
support 2017-09-11 12:24:00
@demianaa Test under 61, chrome, It is OK . Every prefix or just U1 C1 , can you told me the exact prefix?
Reply
demianaa 2017-09-11 12:40:27
@support Version 61.0.3163.79 (Officiel version) (64-bit) is not OK. Prefix's involved (that I've noticed): D, J, R, C, U ( all my Q's are U's so I don't no abaut those =) )
Reply
Tutorials 2017-09-11 12:52:52
@demianaa Hi , After I test at Windows10,Chrome Version 61.0.3163.79 (Officiel version) (64-bit) ,it is good. Can you remove the browser caches to try again? Be careful, if you remove the caches ,the crash recovery will be empty.
Reply
demianaa 2017-09-11 13:07:06
Yes I will try later...
Reply
support 2017-09-11 13:11:25
I have changed R15 R14 R4 R3 , ALL saved OK. Chrome windows 61 ![enter image description here][1] [1]: /editor/20170911/59b61a7e7574f.png
Reply
support 2017-09-11 13:11:44
@demianaa I have changed R15 R14 R4 R3 , ALL saved OK. Chrome windows 61 ![enter image description here][1] [1]: /editor/20170911/59b61a7e7574f.png
Reply
demianaa 2017-09-11 22:20:56
@support I really don't think that solves it, You might have been able to save those 4 components and it's possible - and I will certainly try it for all components =) - but it still doesn't open the file correctly (the same way it was saved and the way it is displayed when exported as image or as it is displayed in the project thumbnail). This is still as the images I posted above. Of course You have saved, and overridden the original file, with the jumbled version displayed, so that exported images, for that file are now messed up as well (I have just tested with my own version of the file). Look at R1, R2, JP12, JP13 on the images above, *from the same file* - this issue persist in Chrome (63....) I just hope that once I have rearranged all the labels one more time in Chrome, that they stay arranged! And it's not one or two specific components that messes things up - as lutecki suggests... =)
Reply
demianaa 2017-09-11 23:41:08
@Support OK, after redoing all the labels in Chrome (63...) and saving the project in Chrome, I can reopen the file in Chrome without issue! =) The file still is a mess when I open it in Firefox. So the moral for now? *"Only use EasyEda in Chrome."* I luckily don't have that many files with large amounts of components the need to redone...others might...
Reply
Tutorials 2017-09-12 17:03:13
Hi,@demianaa we fix this at v4.9.1, please try. thanks
Reply
demianaa 2017-09-12 23:13:22
@Tutorials Looks good, both the file in witch I updated the labels, in Chrome, and the older files. Great, thanks for the update =)
Reply
Login or Register to add a comment
goToTop
你现在访问的是EasyEDA海外版,使用建立访问速度更快的国内版 https://lceda.cn(需要重新注册)
如果需要转移工程请在个人中心 - 工程 - 工程高级设置 - 下载工程,下载后在https://lceda.cn/editor 打开保存即可。
有问题联系QQ 3001956291 不再提醒
svg-battery svg-battery-wifi svg-books svg-more svg-paste svg-pencil svg-plant svg-ruler svg-share svg-user 立创EDAlogo 双贱