Small issue : PCB Layout prefix display not always saved
721 3
martin 7 years ago
1. Create a PCB layout from a schematic 2. Add a copper area (GND, say) 3. Set "Copper Zone" to Invisible 3. For a few components, set PrefixDisplay to False. 4. Save the PCB 5. Close PCB 6. Reload PCB -> The PrefixDisplay is still set to False for your components 7. Set "Copper Zone" to visible 8. Save PCB 9. Close PCB 10. Load PCB -> Verify that the components whose PrefixDisplay had been set to False are now "True" Note that it is necessary to toggle the copper zone to trigger the behavior. There may be other triggers, but this one is replicable 100% of the time.
Comments
andyfierman 7 years ago
I can (re-)produce the same bug using these simpler steps: 1) Pick any PCB layout; 2) For a few components, set PrefixDisplay to "No"; 3) Save the PCB; 4) Close PCB; 5) Reload PCB -> The PrefixDisplay is still set to "No" for your components; 6) Save PCB 7) Close PCB 8) Load PCB -> Verify that the components whose PrefixDisplay had been set to "No" are now set to "Yes", i.e. their prefixes are now visible on the PCB again.
Reply
martin 7 years ago
Aaaah! Excellent. So I guess there was a bit of voodoo in my steps. Not a biggie, but it has the potential of messing the silk layer up without your noticing and sending to production...
Reply
dillon 7 years ago
Like this kind of bugs, their are reproduced: Thanks All. Dillon
Reply
Login or Register to add a comment
goToTop
你现在访问的是EasyEDA海外版,使用建立访问速度更快的国内版 https://lceda.cn(需要重新注册)
如果需要转移工程请在个人中心 - 工程 - 工程高级设置 - 下载工程,下载后在https://lceda.cn/editor 打开保存即可。
有问题联系QQ 3001956291 不再提醒
svg-battery svg-battery-wifi svg-books svg-more svg-paste svg-pencil svg-plant svg-ruler svg-share svg-user svg-logo-cn svg-double-arrow
We use cookies to offer you a better experience. Detailed information on the use of cookies on this website is provided in our Privacy Policy. By using this site, you consent to the use of our cookies.