Snap grid is enabled but doesn't work?
184 4
J4n m3y3r 5 months ago
Yesterday I installed the editor on Windows and have created a pcb from a schematic. In the pcb I placed all components, then clicked the canvas to enable snapping. It was already enabled (to 2.54mm). But components do not snap. Only tracks snap to pads. Alt-snap also doesn't work. In summary there is no indication that snap-to-grid in fact works. How do I get it to work? Don't know how to attach a picture. Here is a summary of the settings: * Snap: YES * Grid Size: 2.54mm * Snap Size: 1.27mm * Alt Snap: 0.127mm The grid is visible (default settings).
Comments
andyfierman 5 months ago
"Don't know how to attach a picture." In Chrome, Just drag and drop or Ctrl+C, Ctrl+V or in Chrome and Firefox, click on the image icon in the top bar of the post editing box. Sorry though: I can't replicate your issue.
Reply
cjohnson 5 months ago
At first glance, that's an incredibly small snap size. Change your snap size to like 5 millimeters you should then see the snapping effect.
Reply
J4n m3y3r 5 months ago
I found the solution. The Grid and Grid Size settings in the right pane do NOT, initially, work. They only work after one right-clicks on the canvas and selects a Grid Size. Don't know if this occurs once for a new install, for a new user, or for a new PCB. All I now it didn't work and now it does.
Reply
J4n m3y3r 5 months ago
Note that the desired canvas right-click menu is NOT available when a part is currently selected, even when right-clicking in the empty canvas.
Reply
Login or Register to add a comment
goToTop
你现在访问的是EasyEDA海外版,使用建立访问速度更快的国内版 https://lceda.cn(需要重新注册)
如果需要转移工程请在个人中心 - 工程 - 工程高级设置 - 下载工程,下载后在https://lceda.cn/editor 打开保存即可。
有问题联系QQ 3001956291 不再提醒
svg-battery svg-battery-wifi svg-books svg-more svg-paste svg-pencil svg-plant svg-ruler svg-share svg-user svg-logo-cn svg-double-arrow
We use cookies to offer you a better experience. Detailed information on the use of cookies on this website is provided in our Privacy Policy. By using this site, you consent to the use of our cookies.