Undo active wire undoes previous wire
670 3
example 7 years ago
**BUG** Concise problem statement: If a mistake is made during routing a schematic wire (call this the 'active' wire), then Ctrl+Z does not undo anything to do with the active wire. In fact, 'Undo' undoes the whole of the wire that was completed immediately *before* the active wire was started. Steps to reproduce bug: 1. place 3 resistors on the schematic canvas. 2. start a first new wire at pin2 of R1 and end it at pin 1 of R2. 3. start a second new wire at pin2 of R2, connect pin1 of R3 then turn a 90 corner to begin return wire towards - but do not attach it to - pin 1 of R2. 4. Do not end wire or end wiring mode. 5. Do Ctrl+Z. Results: wire from pin2 of R1 to pin 1 of R2 is deleted. Expected results: The last 90 corner or maybe the whole of the second wire starting at pin 2 of R2 should be deleted. Url: n/a Browser:Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/30.0.1599.114 Chrome/30.0.1599.114 Safari/537.36
Comments
dillon 8 years ago
:). Undo can't be used in such situation. But if you want to delete the last segment, try to press 'Del' key. This operation will compate withe other software. If this is what you want, please make the topic 'Fixed'
Reply
example 8 years ago
I had not found this feature before. It works OK in Chrome, Chromium and Firefox on my Linux box. There is one slight strangeness: the last section is not deleted on the first press of the Del key. I am not quite sure about this but it seems that if you daw two segments then you have to press the Del key twice for the last segment to be deleted. If you draw 5 or 6 segments then you have to press the key about 3 times before the last segment is deleted. Once a segment has been deleted than each press of the Del key deletes an earlier segment. I will check it on XP next week.
Reply
example 7 years ago
"I will check it on XP next week." It behaves the same in Firefox on WinXP SP3. The behaviour is a bit strange but it is the same in all the browsers and OS I have tried so I have marked it as "Solved".
Reply
Login or Register to add a comment
goToTop
你现在访问的是EasyEDA海外版,使用建立访问速度更快的国内版 https://lceda.cn(需要重新注册)
如果需要转移工程请在个人中心 - 工程 - 工程高级设置 - 下载工程,下载后在https://lceda.cn/editor 打开保存即可。
有问题联系QQ 3001956291 不再提醒
svg-battery svg-battery-wifi svg-books svg-more svg-paste svg-pencil svg-plant svg-ruler svg-share svg-user svg-logo-cn svg-double-arrow
We use cookies to offer you a better experience. Detailed information on the use of cookies on this website is provided in our Privacy Policy. By using this site, you consent to the use of our cookies.