Update PCB / Auto Router
580 17
w4mmp 7 months ago
**BUG** Concise problem statement: 1)The system always reports the PCB is being updated when the Update PCB is applied even thou nothing has changed in the schematic pages. 2)The auto router never completes. 3)The system frequently reports "Network Error" when attempting to save the PCB. This happens only when attempting to save the PCB. The schematics save properly. It appears this PCB layout is a bit too complex for EasyEDA. I would attach the project to this post but I don't see a why to do it. The project is named Maximus Steps to reproduce bug: 1. Install Maximus project 2. Update PCB 3. Run auto router Results: Expected results: Browser: Fire Fox 58.0.2 (64 bit) Regards, Ron
Comments
andyfierman 2018-02-25 06:54:49
`I would attach the project to this post but I don't see a why to do it.` All your projects are private so only you can see them. You first need to make your project public. Then you need to share the URL to it. Please see: https://easyeda.com/Doc/Tutorial/Share.htm#Sharing
Reply
w4mmp 2018-02-25 09:17:13
Hi, OK, I think I did this correctly. Here is the link: https://easyeda.com/551a2647f5754fedae2b8143a0fba790/Maximus-3659c25ec679447bb0eceea3b066fc04
Reply
Summving 2018-02-27 11:01:15
Hi After checking your project 1.Yes, it is a known issue, we have fixed this issue at next big version 2.Your PCB seems complicated, and your PCB have many auto route rules, and the PCB Space constraints, the auto router can not finish. the more detail you can refer to https://easyeda.com/Doc/Tutorial/PCB.htm#Auto-Router https://easyeda.com/Doc/Tutorial/PCB.htm#Local-Auto-Router 3.this issue can't repeat at my side, can you check your network? or try to change others network. thank you
Reply
w4mmp 2018-02-27 11:25:47
Hi, 1. Thanks for the info. What is the release date of the next big release? 2. Are you saying that the auto router can not handle this project? 3. The problem is intermittent. My location has only DSL available with very slow up load times. Perhaps the server timeout value needs to be larger. Regards, Ron Patton
Reply
w4mmp 2018-03-03 13:09:08
Hello, After many hours working with the auto router, the PCB was successfully routed. However, (after researching all the available resources) I would like to know why the auto router continues to route certain ground tracks. All the components that have a ground connection should be connected to the top (or bottom) copper area. They do not need tracks between various components. https://easyeda.com/551a2647f5754fedae2b8143a0fba790/Maximus-3659c25ec679447bb0eceea3b066fc04 Regards, Ron Patton
Reply
Tutorials 2018-03-06 11:51:37
Hi If you don't need the GND auto route, you need to ignore it.
Reply
boyarinovigor 2018-03-08 14:00:17
@Tutorials I ignore them. I mark "MLA ignore". The program shows me that no connections.![2018-03-08.png](//image.easyeda.com/pullimage/2QNSK0i53iKgqfxQxkB44pjm1Ut5GkiywgjRZI7G.png)
Reply
boyarinovigor 2018-03-08 14:00:58
"GND ignore"
Reply
boyarinovigor 2018-03-08 14:08:23
in Auto Router
Reply
boyarinovigor 2018-03-08 15:18:23
and "VCC ignore"
Reply
boyarinovigor 2018-03-08 16:00:58
![2018-03-08 (1).png](//image.easyeda.com/pullimage/uXp3y7AUEZsksnqez8qLBGRwVlMPg20xE1dCi38x.png)
Reply
boyarinovigor 2018-03-08 16:01:27
bottom layer is GND
Reply
boyarinovigor 2018-03-08 16:15:13
some time passed and error messages disappeared.
Reply
Tutorials 2018-03-08 20:32:21
@boyarinovigor Can you share your project with the public? I need to check it out. thanks
Reply
boyarinovigor 2018-03-08 21:23:34
@Tutorials done
Reply
w4mmp 2018-03-08 22:51:09
OK, here is a project that demonstrates the ground routing problem.  This project has a top and bottom copper area covering the entire PCB.  I don't what is meant by "ignore" as I don't see that as an option in the auto router.  What I do is tell the auto router to skip GND.  After routing, all components that have a GND attachment route properly and are attached to either the top or bottom copper area.  However, there are RAT lines between the GND terminals of R9,R10 and J1 so the Net display of the Design Manager shows the RED X for GND. There is a bug in the auto router where it fails to recognize the existence of the copper area in certain cases. [https://easyeda\.com/551a2647/S\_Meter\_Signal\_Generator\-d8849e227944425d8706815c708c3f87](https://easyeda.com/551a2647/S_Meter_Signal_Generator-d8849e227944425d8706815c708c3f87)
Reply
w4mmp 2018-03-08 23:35:45
Here is another example of the issue: [https://easyeda.com/551a2647/USB_Isolator-cf9d639db25e49eb865517106728cdf6](https://easyeda.com/551a2647/USB_Isolator-cf9d639db25e49eb865517106728cdf6) There are no DRC errors.  There are RAT lines between L4, D2  and between L7,C8
Reply
Login or Register to add a comment
goToTop
你现在访问的是EasyEDA海外版,使用建立访问速度更快的国内版 https://lceda.cn(需要重新注册)
如果需要转移工程请在个人中心 - 工程 - 工程高级设置 - 下载工程,下载后在https://lceda.cn/editor 打开保存即可。
有问题联系QQ 3001956291 不再提醒
svg-battery svg-battery-wifi svg-books svg-more svg-paste svg-pencil svg-plant svg-ruler svg-share svg-user svg-logo-cn svg-double-arrow
We use cookies to offer you a better experience. Detailed information on the use of cookies on this website is provided in our Privacy Policy. By using this site, you consent to the use of our cookies.