VCC, +5V netlabels not working in simulation
75 1
Sofia Paixão 1 week ago
I was trying to design a simple amplifier circuit in simulation mode in EasyEDA, and after connecting to GND and VCC netlabels, I was very confused as to why it was telling me I had no voltage sources, once I tried to run the simulation in DC OP mode; specifically, this message: _"Current circuit doesn't has Voltage Resource or Current Resource symbol, please place it first at left side EELib or Spice Library"_ After digging a bit, it seems like VCC/GND netlabels are not being associated with a voltage source anymore. I tried opening this circuit [https://easyeda.com/andyfierman/vcc-vs-5v-netflag-problem](https://easyeda.com/andyfierman/vcc-vs-5v-netflag-problem) , which mentions a slightly different problem triggered by two voltage sources in the same net, and: \- for Sheet1 \(an example presented as working\) File \-\> Export Netlist \-\> LTSpice fails with the same error \- for Sheet4 \(also presented as working\)\, it ignores all Netlabel voltage sources in the export Is this intentional, or a regression? For anyone with the same issue, I managed to circumvent it by replacing all voltage netlabels by its explicit equivalent: a DC source connected to GND.
Comments
andyfierman 1 week ago
This is a deliberate change because the net label solution (a) teaches bad habits in setting up simulations and (b) did not work in all possible situations. The placement of explicit sources follows the de-facto industry standard for spice simulation tools. Please refer to the Simulation Tutorial for more information about the need to explicit sources in simulations and how to configure Voltage and Current Sources.
Reply
Login or Register to add a comment
goToTop
你现在访问的是EasyEDA海外版,使用建立访问速度更快的国内版 https://lceda.cn(需要重新注册)
如果需要转移工程请在个人中心 - 工程 - 工程高级设置 - 下载工程,下载后在https://lceda.cn/editor 打开保存即可。
有问题联系QQ 3001956291 不再提醒
svg-battery svg-battery-wifi svg-books svg-more svg-paste svg-pencil svg-plant svg-ruler svg-share svg-user svg-logo-cn svg-double-arrow
We use cookies to offer you a better experience. Detailed information on the use of cookies on this website is provided in our Privacy Policy. By using this site, you consent to the use of our cookies.